Anleitung: TP-Link TL-WR1043ND mit DD-WRT flashen

UPDATE Januar 2013:
In den Kommentaren kann man lesen, dass wohl angeblich nur die Revisionen 1.1 und 1.4 kompatibel sind. Die anderen machen offenbar Probleme. (Dies habe ich nicht nachprüfen können, daher dieser Hinweis unter vorbehalt.)

Vorbereitung und Ausgangsbasis

  • DD-WRT Fähiger Router TP-Link TL-WR1043ND
  • Netzwerkkabel (liegt im Lieferumfang des Reuthers bei)
  • Sicherheitshalber noch mal überprüfen, ob der Router mit der DD-WRT unterstützt wird Router Database
Schritt-Für-Schritt Anleitung
Vorbereitung:
1. Herunterladen der Firmware: Ladet nicht nur die DD-WRT Firmware, sondern auch die „Killer-Firmware“, welche den Router auf das flashen vorbereitet. Wählt über die Router Database das Produkt aus und ladet euch die Firmware herunter: Special image for initial Flashing UND das Webflash image
Die Alte Firmware mit dem Kill-Image löschen
2. Deaktivieren sie an ihren Rechner das WLAN und deaktivieren sie eventuell noch die Firewall
Schließen sie den WR1043 via LAN Kabel an ihren Rechner an und rufen sie die Standard IP im Browser auf, mit der der Router angemeldet ist (in der Regel 192.168.1.1).
3. Klicken sie sich durch das Menü, bis sie zum Feld Firmware Update kommen: System-Tool
4. Danach wählen sie Firmware Update aus.
5. Danach wählen sie über Datei Auswählen die Firmware „Factory-to-DDWRT.bin“ aus.
6. Bestätigen sie nun das Update der Firmware zweifach:
7. Lassen sie das Update in Ruhe ausführen. Gehen sie in die Küche und setzen sie Wasser für einen Instant Cappuccino oder Tee an. Kehren sie zurück. Der Router müsste nun unter 192.168.1.1 neu gebotet haben und die DD-WRT Oberfläche müsste zu sehen sein.
8. Führen sie einen 30-30-30 Reset aus:
Lassen sie den Router wie gewohnt am LAN Port des Rechners stecken und Betätigen sie 30 Sekunden den Reset-Knopf mit einen Spitzen Gegenstand. Nach 30 Sekunden halten sie WEITERHIN den Resetknopf ununterbrochen gedrückt und ziehen den Netzstekcer aus dem Router (nun ist der Router ohne Strom). Nach weiteren 30 Sekunden mit WEITERHIN gedrückter Resettaste stecken sie den Netzstecker wieder in den Router und warten bei WEITERHIN gedrückter Resettaste noch mal 30 Sekunden. Dadurch wird der Router zurückgesetzt. insgesamt haltet ihr als 1 Minute und 30 Sekunden den Restknopf gedrückt.
9. Öffnen nun die IP 192.168.1.1. im Browserfenster und geht einen Adminnamen und Root Passwort für die DDWRT Factory Firmware ein. Ihr habt nun die Vorab Factory Firmware auf dem Router. Dies ist aber noch nicht die Endfirmware. Diese wird im nächsten Schritt aufgespielt.
Aufspielen der DD-WRT Firmware
10. Geht nun zu „Administration“ –> „Firmware Update“ und wähl dort nun die zweite Firmware aus: „xxxwebflashimage.bin“ aus und führt das Upgrade der Firmware durch.
11. Nun wartet ihr bis der Router neustartet

12. Nachdem der Router neugestartet ist und ihr unter 192.168.1.1. wieder die DD-WRT Oberfläche seht, führt erneut einen 30-30-30 Reset aus (Beschreibung siehe oben).

13. GESCHAFT. Nun habt ihr einen Router, auf dem die DD-WRT Firmware läuft.

Quellen (Englische Anleitung)

markiert , , , , , , , , , , , , , , ,

18 Gedanken zu „Anleitung: TP-Link TL-WR1043ND mit DD-WRT flashen

  1. refilixlix sagt:

    hä? webflash image benötigt man wenn man bereits eine dd-wrt firmware drauf hat. das factory image wenn man es komplett neu installiert. daher ist der zweite schritt nicht notwendig.

    besser erklär hier:
    http://b-red.net/2010/07/04/tp-link-tl-wr1043nd-mit-dd-wrt/

  2. St0re sagt:

    Danke für diese Anleitung. Kleiner Tip für die Leute mit den Kabelmodem von Thomsen (KabelDeutschland): Wenn ihr keine Wan ip bekommt einfach mal Router an lassen und das Kabelmodem kurz Stromlos machen. Hat mich fast zum Kotzen gebracht.

  3. @St0re – Habe auch ein Problem mit einem Thomson Modem am Wan Port. Stromlos machen hilft bei mir leider nicht. Es leuchtet nicht mal der Wan-Port am TP-Link bzw. der Lan-Port am Thomson auf. Sehr strange. So kann ich DD-WRT natürlich nicht brauchen. Hat jemand noch eine Idee? Es ist als wäre der WAN-Port deaktiviert.

  4. Problem lag nicht am Thomson, sondern daran dass ich eine zu neue Firmware draufhatte, bei der beim Flashen der WAN Port deaktiviert wird. Hier ein Workaround: http://nearlydeaf.com/?p=1109

  5. Aki sagt:

    Es fehlt der Hinweis, das nur die Revisionen 1.1 und 1.4 kompatibel sind. Die anderen machen offenbar Probleme.

  6. Gunilein sagt:

    Ich brauche Hilfe !!
    Bei mir kommt immer diese Fehlermeldung:
    Fehlercode: 18005-Upgrade erfolglos,die Version der aktualisierten Datei war fehlerhaft. Bitte überprüfen Sie den Dateinamen.
    Ich kann auch keine originale Firmware einspielen kommt immer das selbe dabei herraus.
    Danke.

  7. Martin sagt:

    Hallo,

    ich habe die Revisionen 1.0, das nur 1.1 und 1.4 gehen ist somit nicht richtig. Ich habe die DD-WRT v24-sp2 (02/11/13) std – build 20675 Firmware sauber ohne Probleme am laufen 300 Mbit sind ebenfalls damit kein Problem! Mit der normalen DD-WRT wie oben beschrieben ging max. 108 MBit.

  8. Solutioner sagt:

    Hallo,
    danke für die gute Anleitung. eine kurze Frage habe ich: neben dem 1043 hab ich hier noch einen TP link Range extender (WA 830RE). muss ich auf den extender auch DD-WRT drauf spielen oder verlängert der das WLAN auch mit der original firmware? Und falls nicht: kannst du mir evtl. sagen ob/wie/welche FW ich auf den Extender schieben soll?
    Gruß
    Peter

  9. Peter sagt:

    ich kann irgentwie nur noch folgenden eintrag finden TP-Link TL-WR1043N(D) 1.x
    ist das der selbe Router wie der TP-Link TL-WR1043ND?

    • Administrator sagt:

      Ich denke es wird der selbe Router sein. Suche doch mal, ob man ihn flashen kann. Nicht dass die die Chipsätze und Firmware abgeriegelt haben.

  10. Hallo und zwar habe ich folgendes Problem habe jetzt den 2ten Router auch ein 1043ND, jedoch spiele ich to factory auf und kann den Router danach nicht mehr erreichen!!!
    Woran kann es liegen, dass es bei mir mittlerweile schon mit dem 2ten Router nicht funktioniert??

    • Administrator sagt:

      Mmh, gründe kann es immer viele geben. Hast Du schonmal einen Hardreset gemacht? (Vielleicht ist die Firmware auf deinen Router zu neu?). Hast Du diesbezüglich schon mal gegoogelt?

  11. Christian sagt:

    hi habe das update gemacht das erste und jetzt geht garnix mehr hilfe

  12. Christian sagt:

    hallo habe das erste gemacht und bei mir geht garnix mehr kann nicht mehr zugreifen und das cmd funktioniert bei mir auch nicht falscher befehl habe es bei win 7 und 8 ausprobiert dringend hilfe

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.